GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
BACKLIGHT(9) FreeBSD Kernel Developer's Manual BACKLIGHT(9)

backlight, backlight_register, backlight_destroy, BACKLIGHT_GET_STATUS, BACKLIGHT_SET_STATUS, —
BACKLIGHT methods

device backlight
#include <backlight_if.h>
#include <sys/sys/backlight.h>

int
BACKLIGHT_GET_STATUS(device_t bus, struct backlight_props *props);

int
BACKLIGHT_SET_STATUS(device_t bus, struct backlight_props *props);

struct cdev *
backlight_register(const char *name, device_t dev);

int
backlight_destroy(struct cdev *cdev);

The backlight driver provides a generic way for handling a panel backlight.

Drivers for backlight system register themselves globally using the backlight_register() function. They must define two methods, BACKLIGHT_GET_STATUS() which is used to query the current brightness level and BACKLIGHT_SET_STATUS() which is used to update it.

BACKLIGHT_GET_STATUS(device_t bus, struct backlight_props *props)
Driver fills the current brightless level and the optional supported levels.
BACKLIGHT_SET_STATUS(device_t bus, struct backlight_props *props)
Driver update the backlight level based on the brightness member of the props struct.

/dev/backlight/*
 

The backlight interface first appear in FreeBSD 13.0. The backlight driver and manual page was written by Emmanuel Vadot <manu@FreeBSD.org>.
October 2, 2020 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.