GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
BUF_TIMELOCK(9) FreeBSD Kernel Developer's Manual BUF_TIMELOCK(9)

BUF_TIMELOCK
locks a buffer

#include <sys/param.h>
#include <sys/systm.h>
#include <sys/uio.h>
#include <sys/bio.h>
#include <sys/buf.h>

int
BUF_TIMELOCK(struct buf *bp, int locktype, char *wmesg, int catch, int timo);

The BUF_TIMELOCK() function locks the given buffer, and limits the amount of time it will sleep to timo and OR's catch into the sleep's priority. wmesg is the wmesg used in the sleep.

Its arguments are:

bp
The buffer to lock.
locktype
Flags controlling the type of lock. See lockmgr(9) for details.
wmesg
The wmesg used in any sleeps while acquiring the lock.
catch
Priority OR'd into the sleep's priority.
timo
The timeout for any sleeps encountered during the lock.

A value of 0 is returned on success. See lockmgr(9) for details on non-zero return values.

buf(9), BUF_LOCK(9), BUF_UNLOCK(9), lockmgr(9)

This manual page was written by Chad David <davidc@acns.ab.ca>.
July 9, 2001 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.