GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
BUS_RELEASE_RESOURCE(9) FreeBSD Kernel Developer's Manual BUS_RELEASE_RESOURCE(9)

bus_release_resource
release resources on a bus

#include <sys/param.h>
#include <sys/bus.h>


#include <machine/bus.h>
#include <sys/rman.h>
#include <machine/resource.h>

int
bus_release_resource(device_t dev, int type, int rid, struct resource *r);

Free a resource allocated by bus_alloc_resource(9). The resource must not be in use on release, i.e., call an appropriate function before (e.g. bus_teardown_intr(9) for IRQs).
  • dev is the device that owns the resource.
  • type is the type of resource that is released. It must be of the same type you allocated it as before. See bus_alloc_resource(9) for valid types.
  • rid is the resource ID of the resource. The rid value must be the same as the one returned by bus_alloc_resource(9).
  • r is the pointer to struct resource, i.e., the resource itself, returned by bus_alloc_resource(9).

EINVAL is returned, if the device dev has no parent, 0 otherwise. The kernel will panic, if it cannot release the resource.

	/* deactivate IRQ */
	bus_teardown_intr(dev, foosoftc->irqres, foosoftc->irqid);

	/* release IRQ resource */
	bus_release_resource(dev, SYS_RES_IRQ, foosoftc->irqid,
		foosoftc->irqres);

	/* release I/O port resource */
	bus_release_resource(dev, SYS_RES_IOPORT, foosoftc->portid,
		foosoftc->portres);

bus_alloc_resource(9), device(9), driver(9)

This manual page was written by Alexander Langer <alex@big.endian.de>.
May 18, 2000 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.