GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
DEVCTL_NOTIFY(9) FreeBSD Kernel Developer's Manual DEVCTL_NOTIFY(9)

devctl_notify
Send a message, via devctl, to userland

#include <sys/devctl.h>

void
devctl_notify(const char *system, const char *subsystem, const char *type, const char *data);

Send a notification to user land via devctl(4). See devctl(4) for the format of these messages.

The devctl_notify function creates a string using the following template:

snprintf(buffer, sizeof(buffer), "!system=%s subsystem=%s type=%s",
   system, subsystem, type);

The system, subsystem, and type pointers cannot be NULL.

The data argument may be NULL (for no additions) or a message formatted properly for devctl(4). A space will be added to the above template and this argument copied verbatim to form the message passed to userland. Senders should balance between only passing data that userland can not discover itself and sending all the data userland will want to use to decide what to do with the message.

The current total message length limit is just under 1kb. Senders should try to remain well below this limit.

devctl(4), devd(8)

This manual page was written by M. Warner Losh
September 22, 2020 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.