GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
DEVICE_GET_IVARS(9) FreeBSD Kernel Developer's Manual DEVICE_GET_IVARS(9)

device_get_ivars, device_set_ivars
access bus private variables

#include <sys/param.h>
#include <sys/bus.h>

void *
device_get_ivars(device_t dev);

void
device_set_ivars(device_t dev, void *ivar);

The device_get_ivars() function returns the bus-specific instance variables of a device.

The device_set_ivars() function sets the bus-specific instance variables of a device.

Typically, only bus drivers will use these functions. The kernel assumes that the bus driver will manage this memory, and no automatic memory allocation or deallocation happens. Client drivers should access ivars through the BUS_READ_IVAR(9) interface instead.

device(9)

This manual page was written by Doug Rabson.
June 16, 1998 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.