GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
DEVICE_PRINTF(9) FreeBSD Kernel Developer's Manual DEVICE_PRINTF(9)

device_printf
formatted output conversion

#include <sys/param.h>
#include <sys/bus.h>

int
device_printf(device_t dev, const char *fmt, ...);

The device_printf() function is a convenience interface to the printf(9) function. It outputs the name of the dev device, followed by a colon and a space, and then what printf(9) would print if you passed fmt and the remaining arguments to it.

The device_printf() function returns the number of characters displayed.

printf(3), printf(9)
April 21, 2003 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.