GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
ETHER_GEN_ADDR(9) FreeBSD Kernel Developer's Manual ETHER_GEN_ADDR(9)

ether_gen_addr
generate an arbitrary MAC address for use

#include <sys/types.h>
#include <sys/socket.h>
#include <net/if.h>
#include <net/if_var.h>
#include <net/ethernet.h>

void
ether_gen_addr(struct ifnet *ifp, struct ether_addr *hwaddr);

The ether_gen_addr() function generates an arbitrary MAC address for use by an ethernet interface that does not have an assigned address.

By default, ether_gen_addr attempts to generate a stable MAC address using the hostid of the jail that the ifp is being added to. During early boot, the hostid may not be set on machines that haven't yet populated /etc/hostid, or on machines that do not use loader(8).

ether_gen_addr can fail to derive a MAC address due to memory allocation failure, or because the hostid has not been populated. In these cases, a locally-administered unicast MAC address will be randomly generated and returned via the hwaddr parameter.

If ether_gen_addr succeeds, then it will return a MAC address in the FreeBSD Foundation OUI, “58:9c:fc”, via the hwaddr parameter.

This manual page was written by Kyle Evans <kevans@FreeBSD.org>.
June 1, 2021 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.