GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
OF_CHILD(9) FreeBSD Kernel Developer's Manual OF_CHILD(9)

OF_child, OF_parent, OF_peer
navigate device tree

#include <dev/ofw/ofw_bus.h>
#include <dev/ofw/ofw_bus_subr.h>

phandle_t
OF_child(phandle_t node);

phandle_t
OF_parent(phandle_t node);

phandle_t
OF_peer(phandle_t node);

OF_child() returns the phandle value of the first child of the node. Zero is returned if there are no child nodes.

OF_parent() returns the phandle for the parent of the node. Zero is returned if node is the root node.

OF_peer() returns the phandle value of the next sibling of the node. Zero is returned if there is no sibling node.

phandle_t node, child;
 ...
for (child = OF_child(node); child != 0; child = OF_peer(child) {
	...
}

OF_finddevice(9)

This manual page was written by Oleksandr Tymoshenko <gonzo@FreeBSD.org>.
April 9, 2018 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.