GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
PCI_IOV_INIT(9) FreeBSD Kernel Developer's Manual PCI_IOV_INIT(9)

PCI_IOV_INIT
enable SR-IOV on a PF device

#include <sys/bus.h>
#include <machine/stdarg.h>
#include <sys/nv.h>
#include <dev/pci/pci_iov.h>

int
PCI_IOV_INIT(device_t dev, uint16_t num_vfs, const nvlist_t *pf_config);

The PCI_IOV_INIT() method is called by the PCI Single-Root I/O Virtualization (SR-IOV) infrastucture when the user requests that SR-IOV be enabled on a Physical Function (PF). The number of Virtual Functions (VFs) that will be created is passed to this method in the num_vfs argument.

If the driver requested device-specific PF configuration parameters via a PF schema in its call to pci_iov_attach(9), those parameters will be available in the pf_config argument. All configuration parameters that were either set as required parameters or that had a default value set in the PF schema are guaranteed to be present in pf_config. Configuration parameters that were neither set as required nor were given a default value are optional and may or may not be present in pf_config. pf_config will not contain any configuration parameters that were not specified in the PF schema. All configuration parameters will have the correct type and are in the range of valid values specified in the schema.

If this method returns successfully, then this method will not be called again on the same device until after a call to PCI_IOV_UNINIT(9).

Returns 0 on success, otherwise an appropriate error is returned. If this method returns an error then the SR-IOV configuration will be aborted and no VFs will be created.

nv(9), pci(9), PCI_IOV_ADD_VF(9), pci_iov_schema(9), PCI_IOV_UNINIT(9)

This manual page was written by Ryan Stone <rstone@FreeBSD.org>.
May 28, 2015 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.