GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
PMAP_QENTER(9) FreeBSD Kernel Developer's Manual PMAP_QENTER(9)

pmap_qenter, pmap_qremove
manage temporary kernel space mappings

#include <sys/param.h>
#include <vm/vm.h>
#include <vm/pmap.h>

void
pmap_qenter(vm_offset_t sva, vm_page_t *m, int count);

void
pmap_qremove(vm_offset_t sva, int count);

The pmap_qenter() function accepts a linear array of count pointers to wired pages *m, and enters each of these pages into the kernel virtual address (KVA) space, beginning at the address sva. The pages are mapped non-executable, if possible. (For example, non-PAE i386 has no capability to map pages non-executable.)

The pmap_qremove() function tears out a mapping from the kernel virtual address space, beginning at sva and for count pages.

The pmap_qenter() function is intended for temporary mappings that do not require page modification or reference counting. Old mappings are simply overwritten. The pages must be wired into physical memory.

The corresponding pmap_qremove() function is intended to remove such temporary mappings.

pmap(9)

This manual page was written by Bruce M Simpson <bms@spc.org>.
February 15, 2018 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.