GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
PMAP_REMOVE(9) FreeBSD Kernel Developer's Manual PMAP_REMOVE(9)

pmap_remove, pmap_remove_all, pmap_remove_pages
remove pages from a physical map

#include <sys/param.h>
#include <vm/vm.h>
#include <vm/pmap.h>

void
pmap_remove(pmap_t pmap, vm_offset_t sva, vm_offset_t eva);

void
pmap_remove_all(vm_page_t m);

void
pmap_remove_pages(pmap_t pmap);

The pmap_remove() function removes the range of addresses between sva and eva from the physical map pmap. If eva is less than sva, then the result is undefined. It is assumed that both sva and eva are page-aligned addresses.

The pmap_remove_all() removes the physical page m from all physical maps in which it resides, and reflects back the modify bits to the appropriate pager.

The pmap_remove_pages() function removes all user pages from the physical map pmap. This function is called when a process exits to run down its address space more quickly than would be the case for calling pmap_remove().

pmap(9)

This manual page was written by Bruce M Simpson <bms@spc.org>.
July 21, 2003 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.