GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
PMAP_RESIDENT_COUNT(9) FreeBSD Kernel Developer's Manual PMAP_RESIDENT_COUNT(9)

pmap_resident_count, pmap_wired_count
return page resident and wiring statistics

#include <sys/param.h>
#include <vm/vm.h>
#include <vm/pmap.h>

long
pmap_resident_count(pmap_t pmap);

long
pmap_wired_count(pmap_t pmap);

The pmap_resident_count() and pmap_wired_count() macros allow pmap consumers to retrieve statistics from the pm_stats member of the machine-dependent structure struct pmap.

Both functions are defined as in-line macros. The members which they access have type long.

The pmap_resident_count() returns the number of pages in the physical map pmap which are currently resident in main memory.

The pmap_wired_count() returns the number of pages in the physical map pmap which are currently wired into in main memory.

pmap(9)

This manual page was written by Bruce M Simpson <bms@spc.org>.
July 21, 2003 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.