GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
P_CANSEE(9) FreeBSD Kernel Developer's Manual P_CANSEE(9)

p_cansee
determine visibility of a process

#include <sys/param.h>
#include <sys/proc.h>

int
p_cansee(struct thread *td, struct proc *p);

This function can be used to determine if a given process p is visible to the thread td, where the notion of “visibility” may be read as “awareness of existence”.

The function is implemented using cr_cansee(9), and the dependencies on sysctl(8) variables documented in the cr_cansee(9) manual page apply.

The p_cansee() function returns 0 if the process denoted by p is visible by thread td, or a non-zero error return value otherwise.

[]
Process p is not visible to thread td as determined by cr_cansee(9).
[]
Thread td has been jailed and process p does not belong to the same jail as td.
[]
The MAC subsystem denied visibility.

jail(2), sysctl(8), cr_cansee(9), mac(9), p_candebug(9), prison_check(9)
November 19, 2006 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.