GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
UIDINFO(9) FreeBSD Kernel Developer's Manual UIDINFO(9)

uidinfo, uihashinit, uifind, uihold, uifree
functions for managing UID information

#include <sys/param.h>
#include <sys/proc.h>
#include <sys/resourcevar.h>

void
uihashinit(void);

struct uidinfo *
uifind(uid_t uid);

void
uihold(struct uidinfo *uip);

void
uifree(struct uidinfo *uip);

The uidinfo family of functions is used to manage uidinfo structures. Each uidinfo structure maintains per uid resource consumption counts, including the process count and socket buffer space usage.

The uihashinit() function initializes the uidinfo hash table and its mutex. This function should only be called during system initialization.

The uifind() function looks up and returns the uidinfo structure for uid. If no uidinfo structure exists for uid, a new structure will be allocated and initialized. The uidinfo hash mutex is acquired and released.

The uihold() function increases the reference count on uip. uip's lock is acquired and released.

The uifree() function decreases the reference count on uip, and if the count reaches 0 uip is freed. uip's lock is acquired and release and the uidinfo hash mutex may be acquired and released.

uifind() returns a pointer to an initialized uidinfo structure, and should not fail.

This manual page was written by Chad David <davidc@acns.ab.ca>.
July 10, 2001 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.