GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VFLUSH(9) FreeBSD Kernel Developer's Manual VFLUSH(9)

vflush
flush vnodes for a mount point

#include <sys/param.h>
#include <sys/vnode.h>

int
vflush(struct mount *mp, int rootrefs, int flags, struct thread *td);

The vflush() function removes any vnodes in the vnode table that belong to the given mount structure.

Its arguments are:

mp
The mount point whose vnodes should be removed.
rootrefs
The number of references expected on the root vnode. vrele(9) will be invoked on the root vnode rootrefs times.
flags
The flags indicating how vnodes should be handled.
If set, busy vnodes will be forcibly closed.
If set, vnodes with the VV_SYSTEM flag set will be skipped.
If set, only regular files currently opened for writing will be removed.
td
The calling thread.

A value of 0 is returned if the flush is successful; otherwise, EBUSY will be returned.

vgone(9), vrele(9)

This manual page was written by Chad David <davidc@acns.ab.ca>.
November 21, 2001 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.