GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VFS_MOUNT(9) FreeBSD Kernel Developer's Manual VFS_MOUNT(9)

VFS_MOUNT
mount a file system

#include <sys/param.h>
#include <sys/mount.h>
#include <sys/vnode.h>

int
VFS_MOUNT(struct mount *mp);

The VFS_MOUNT() macro mounts a file system into the system's namespace or updates the attributes of an already mounted file system.

The arguments it expects are:

mp
Structure representing the file system.

The VFS_MOUNT() macro is called both to mount new file systems and to change the attributes of an existing file system. If the MNT_UPDATE flag is set in mp->mnt_flag then the file system should update its internal state from the value of mp->mnt_flag. This can be used, for instance, to convert a read-only file system to read-write. It is also used by mountd(8) to update the NFS export information for the file system.

If the MNT_UPDATE flag is not specified, then this is a newly mounted file system. The file system code should allocate and initialize any private data needed to represent the file system (it can use the mp->mnt_data field to store this information).

VFS(9), vnode(9)

This manual page was written by Doug Rabson.
May 23, 2009 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.