GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VFS_ROOT(9) FreeBSD Kernel Developer's Manual VFS_ROOT(9)

VFS_ROOT
return the root vnode of a file system

#include <sys/param.h>
#include <sys/mount.h>
#include <sys/vnode.h>

int
VFS_ROOT(struct mount *mp, int flags, struct vnode **vpp);

Return a locked vnode for the root directory of the file system.

Its arguments are:

mp
The file system.
flags
The lock type. Could be LK_EXCLUSIVE or LK_SHARED. File system is free to ignore the flags argument and instead acquire an exclusive lock.
vpp
Return parameter for the root vnode.

VFS(9), vnode(9)

This manual page was written by Doug Rabson.
May 23, 2009 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.