GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VFS_TIMESTAMP(9) FreeBSD Kernel Developer's Manual VFS_TIMESTAMP(9)

vfs_timestamp
generate current timestamp

#include <sys/param.h>
#include <sys/vnode.h>

void
vfs_timestamp(struct timespec *tsp);

The vfs_timestamp() function fills in tsp with the current time.

The precision is based on the value of the vfs.timestamp_precision sysctl variable:

0
seconds only; nanoseconds are zeroed.
1
seconds and nanoseconds, accurate within 1/HZ.
2
seconds and nanoseconds, truncated to microseconds.
≥3
seconds and nanoseconds, maximum precision.

This manual page was written by Chad David <davidc@acns.ab.ca>.
November 21, 2001 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.