GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VFS_UNMOUNT(9) FreeBSD Kernel Developer's Manual VFS_UNMOUNT(9)

VFS_UNMOUNT
unmount a file system

#include <sys/param.h>
#include <sys/mount.h>
#include <sys/vnode.h>

int
VFS_UNMOUNT(struct mount *mp, int mntflags);

The VFS_UNMOUNT() macro unmounts a file system.

The arguments it expects are:

mp
The file system.
mntflags
Bit-mask of flags for the unmount operation. The flags currently supported by VFS_UNMOUNT() are:
Open files are forcibly closed before the file system is unmounted.

vflush(9), VFS(9), vnode(9)

This manual page was written by Doug Rabson.
May 23, 2009 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.