GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VFS_VGET(9) FreeBSD Kernel Developer's Manual VFS_VGET(9)

VFS_VGET
convert an inode number to a vnode

#include <sys/param.h>
#include <sys/mount.h>
#include <sys/vnode.h>

int
VFS_VGET(struct mount *mp, ino_t ino, int flags, struct vnode **vpp);

The VFS_VGET() looks up or creates a vnode from a (mount, inode#) tuple.

Its arguments are:

mp
The mount point.
ino
The inode representing the file. This is a unique number assigned by the file system when vnodes are first created.
flags
Additional locking flags to pass through to vget(9).
vpp
Return parameter for the vnode.

This is an optional file system entry-point for file systems mainly intended for NFS server use, but many file systems use it internally in VOP_LOOKUP(9) and similar.

If the file system does not support this call, then it should return EOPNOTSUPP.

Please see ffs_vget() in sys/ufs/ffs/ffs_vfsops.c for the canonical example.

VFS(9), vget(9), vnode(9)

This manual page was written by Doug Rabson.
January 7, 2005 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.