GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VGET(9) FreeBSD Kernel Developer's Manual VGET(9)

vget
get a vnode from the free list

#include <sys/param.h>
#include <sys/vnode.h>

int
vget(struct vnode *vp, int lockflag, struct thread *td);

Get a vnode from the free list and increment its reference count.
vp
The vnode to remove from the free list.
lockflag
If non-zero, the vnode will also be locked.

When not in use, vnodes are kept on a free list. The vnodes still reference valid files but may be reused to refer to a new file at any time. Often, these vnodes are also held in caches in the system, such as the name cache.

When a vnode which is on the free list is used again, for instance if the vnode was found in the name cache as a result of a call to VOP_LOOKUP(9) then the new user must call vget() to increment the reference count and remove it from the free list.

vnode(9), vput(9), vref(9), vrele(9)

This manual page was written by Doug Rabson.
July 24, 1996 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.