GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VN_ISDISK(9) FreeBSD Kernel Developer's Manual VN_ISDISK(9)

vn_isdisk
checks if a vnode represents a disk

#include <sys/param.h>
#include <sys/vnode.h>

int
vn_isdisk(struct vnode *vp, int *errp);

The vn_isdisk() function checks to see if vp represents a disk. In order for vp to be a disk, it must be a character device, v_rdev must be valid, and the cdevsw entry's flags must have D_DISK set.

Its arguments are:

vp
The vnode to check.
errp
An integer pointer to store the error number in if the call fails.

If the vnode represents a disk, 1 is returned; otherwise, 0 is returned and errp will contain the error number.

This manual page was written by Chad David <davidc@acns.ab.ca>.
July 9, 2001 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.