GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VOP_ALLOCATE(9) FreeBSD Kernel Developer's Manual VOP_ALLOCATE(9)

VOP_ALLOCATE
allocate storage for a file

#include <sys/param.h>
#include <sys/vnode.h>

int
VOP_ALLOCATE(struct vnode *vp, off_t *offset, off_t *len);

This call allocates storage for a range of offsets in a file. It is used to implement the posix_fallocate system call.

Its arguments are:

vp
The vnode of the file.
offset
The start of the range to allocate storage for in the file.
len
The length of the range to allocate storage for in the file.

The offset and len arguments are updated to reflect the portion of the range that still needs to be allocated on return. A partial allocation is considered a successful operation. The file's contents are not changed.

The file should be exclusively locked on entry and will still be locked on exit.

Zero is returned if the call is successful, otherwise an appropriate error code is returned.

[]
An attempt was made to write a file that exceeds the process's file size limit or the maximum file size.
[]
The file system is full.
[]
An append-only flag is set on the file, but the caller is attempting to write before the current end of file.

vnode(9), VOP_READ(9), VOP_WRITE(9)
October 3, 2013 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.