GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VOP_STRATEGY(9) FreeBSD Kernel Developer's Manual VOP_STRATEGY(9)

VOP_STRATEGY
read or write a file system buffer

#include <sys/param.h>
#include <sys/vnode.h>

int
VOP_STRATEGY(struct vnode *vp, struct buf *bp);

The arguments are:
vp
The vnode that the buffer is for.
bp
The buffer to be read or written.

This call either reads or writes data from a file, depending on the value of bp->b_io.bio_cmd.

The call may block.

Always zero. Errors should be signalled by setting BIO_ERROR on b_ioflags field in struct buf, and setting b_error to the appropriate errno value.

buf(9), vnode(9)

This manual page was written by Doug Rabson.
February 2, 2014 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.