GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
BUS_ADJUST_RESOURCE(9) FreeBSD Kernel Developer's Manual BUS_ADJUST_RESOURCE(9)

bus_adjust_resource
adjust resource allocated from a parent bus

#include <sys/param.h>
#include <sys/bus.h>


#include <machine/bus.h>
#include <sys/rman.h>
#include <machine/resource.h>

int
bus_adjust_resource(device_t dev, int type, struct resource *r, rman_res_t start, rman_res_t end);

This function is used to ask the parent bus to adjust the resource range assigned to an allocated resource. The resource r should have been allocated by a previous call to bus_alloc_resource(9). The new resource range must overlap the existing range of r. The type argument should match the type argument passed to bus_alloc_resource(9) when the resource was initially allocated.

Note that none of the constraints of the original allocation request such as alignment or boundary restrictions are checked by bus_adjust_resource(). It is the caller's responsibility to enforce any such requirements.

The bus_adjust_resource() method returns zero on success or an error code on failure.

Grow an existing memory resource by 4096 bytes.
	struct resource *res;
	int error;

	error = bus_adjust_resource(dev, SYS_RES_MEMORY, res,
	    rman_get_start(res), rman_get_end(res) + 0x1000);

bus_adjust_resource() will fail if:
[]
The dev device does not have a parent device.
[]
The r resource is a shared resource.
[]
The new address range does not overlap with the existing address range of r.
[]
The new address range conflicts with another allocated resource.

bus_alloc_resource(9), bus_release_resource(9), device(9), driver(9)
April 23, 2016 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.