GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
ofw_bus_status_okay(9) FreeBSD Kernel Developer's Manual ofw_bus_status_okay(9)

ofw_bus_get_status, ofw_bus_status_okay, ofw_bus_node_status_okay
check status of the device tree node

#include <dev/ofw/openfirm.h>
#include <dev/ofw/ofw_bus.h>
#include <dev/ofw/ofw_bus_subr.h>

const char *
ofw_bus_get_status(device_t dev);

int
ofw_bus_status_okay(device_t dev);

int
ofw_bus_node_status_okay(phandle_t node);

The "status" property of the device tree node indicates whether the device is enabled or not. Multiple hardware versions might be built using the same base System-on-Chip but with a different set of blocks enabled. It is common to use SoC device tree and only enable/disable device nodes for the derivative boards. The device tree node is considered enabled only if it has "status" property with the value set to either "ok" or "okay".

ofw_bus_get_status() returns the value of the "status" property of the device tree node associated with the device dev. If the node does not have "status" property or there is no node associated with the device the function returns NULL.

ofw_bus_status_okay() returns 1 if the device tree node associated with the device dev has "status" property and its value is either "ok" or "okay".

ofw_bus_node_status_okay() returns 1 if the device tree node node has "status" property and its value is either "ok" or "okay".

This manual page was written by Oleksandr Tymoshenko.
April 8, 2018 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.