GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
OWLL(9) FreeBSD Kernel Developer's Manual OWLL(9)

owll OWLL_WRITE_ONE, OWLL_WRITE_ZERO, OWLL_READ_DATA, OWLL_REASET_AND_PRESENCE
Dallas Semiconductor 1-Wire Link Layer Interface

int
OWLL_WRITE_ONE(device_t lldev, struct ow_timing *timing);

int
OWLL_WRITE_ZERO(device_t lldev, struct ow_timing *timing);

int
OWLL_READ_DATA(device_t lldev, struct ow_timing *timing, int *bit);

int
OWLL_RESET_AND_PRESENCE(device_t lldev, struct ow_timing *timing, int *bit);

The owll interface provides access to the link layer of the Dallas Semiconductor 1-Wire from upper layers of the protocol.

OWLL_WRITE_ONE() and OWLL_WRITE_ZERO() writes a one bit or a zero bit respectively on the 1-Wire bus.

OWLL_READ_DATA() reads one bit from the 1-Wire bus. This is often referred to as a “Read Time Slot” in the 1-Wire device data sheets.

The OWLL_RESET_AND_PRESENCE() function starts a reset sequence and detects if any device(s) are present on the bus. This is the beginning of all 1-Wire transactions.

This interface is intended to be used only by the ow(4) device to talk to the low-level bus. By convention, the device that implements this interface is called owc(4). Only devices that implement own(9) should call these interfaces.

ow(4), owc(4), own(9)

1-Wire is a registered trademark of Maxim Integrated Products, Inc.

The owll driver first appeared in FreeBSD 11.0.

The owll device driver and this manual page were written by Warner Losh.
September 22, 2016 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.