GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VFS_GETVFS(9) FreeBSD Kernel Developer's Manual VFS_GETVFS(9)

vfs_getvfs
returns a mount point given its file system identifier

#include <sys/param.h>
#include <sys/mount.h>

struct mount *
vfs_getvfs(fsid_t *fsid);

The vfs_getvfs() function returns the mount point structure for a file system given its file system identifier. The file system ID should have been allocated by calling vfs_getnewfsid(9); otherwise, it will not be found.

A major user of vfs_getvfs() is NFS, which uses the fsid as part of file handles in order to determine the file system a given RPC is for. If vfs_getvfs() fails to find the mount point related to fsid, the file system is considered stale.

If fsid is found, the mount point for the ID is returned; otherwise, NULL is returned.

if ((mp = vfs_getvfs(&fhp->fh_fsid)) == NULL) {
	error = ESTALE;
	goto out;
}

vfs_getnewfsid(9)

This manual page was written by Chad David <davidc@acns.ab.ca>.
November 21, 2001 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.