GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VM_MAP_INSERT(9) FreeBSD Kernel Developer's Manual VM_MAP_INSERT(9)

vm_map_insert
insert an object into a map

#include <sys/param.h>
#include <vm/vm.h>
#include <vm/vm_map.h>

int
vm_map_insert(vm_map_t map, vm_object_t object, vm_ooffset_t offset, vm_offset_t start, vm_offset_t end, vm_prot_t prot, vm_prot_t max, int cow);

The vm_map_insert() function inserts a mapping for the entire vm_object object into the target map map.

The offset argument specifies the offset into the object at which to begin mapping. The object's size should match that of the specified address range.

The start and end arguments specify the bounds of the mapped object's window in the address space of map.

The cow argument specifies the flags which should be propagated to the new entry, for example, to indicate that this is a copy-on-write mapping.

This function implicitly creates a new vm_map_entry by calling the internal function vm_map_entry_create().

The vm_map_insert() function returns KERN_SUCCESS if the mapping could be made successfully.

Otherwise, KERN_INVALID_ADDRESS will be returned if the start of the range could not be found, or KERN_NO_SPACE if the range was found to be part of an existing entry or if it overlaps the end of the map.

vm_map(9)

This manual page was written by Bruce M Simpson <bms@spc.org>.
January 11, 2013 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.