GSP
Quick Navigator

Search Site

Unix VPS
A - Starter
B - Basic
C - Preferred
D - Commercial
MPS - Dedicated
Previous VPSs
* Sign Up! *

Support
Contact Us
Online Help
Handbooks
Domain Status
Man Pages

FAQ
Virtual Servers
Pricing
Billing
Technical

Network
Facilities
Connectivity
Topology Map

Miscellaneous
Server Agreement
Year 2038
Credits
 

USA Flag

 

 

Man Pages
VREF(9) FreeBSD Kernel Developer's Manual VREF(9)

vref, vrefl
increment the use count for a vnode

#include <sys/param.h>
#include <sys/vnode.h>

void
vref(struct vnode *vp);

void
vrefl(struct vnode *vp);

Increment the v_usecount field of a vnode.
vp
the vnode to increment

Each vnode maintains a reference count of how many parts of the system are using the vnode. This allows the system to detect when a vnode is no longer being used and can be safely recycled for a different file.

Any code in the system which is using a vnode (e.g. during the operation of some algorithm or to store in a data structure) should call vref() or vrefl().

vref() locks the vnode interlock while vrefl() expects the interlock to already be held.

vget(9), vnode(9), vput(9), vrefcnt(9), vrele(9)

This manual page was written by Doug Rabson.
January 18, 2016 FreeBSD 13.1-RELEASE

Search for    or go to Top of page |  Section 9 |  Main Index

Powered by GSP Visit the GSP FreeBSD Man Page Interface.
Output converted with ManDoc.